IPointSetIteratorReadPoints Method |
Implement this method to fill the provided buffer with points up to the number of maximum points for
which the buffer was allocated.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxint ReadPoints(
IntPtr buffer,
int bufferSize
)
Function ReadPoints (
buffer As IntPtr,
bufferSize As Integer
) As Integer
int ReadPoints(
IntPtr buffer,
int bufferSize
)
abstract ReadPoints :
buffer : IntPtr *
bufferSize : int -> int
Parameters
- buffer IntPtr
-
Memory buffer into which the points should be written. The buffer was allocated
by Revit and it is guaranteed to be valid for the duration of the call.
- bufferSize Int32
-
The maximum number of CloudPoint objects that may be copied into the buffer.
Return Value
Int32
The actual number of CloudPoint objects placed in the buffer (can be less than the
length of the buffer). If there are no more points available, return 0.
See Also