TableViewGetCellText Method |
Gets the cell's text based on its type
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string GetCellText(
SectionType sectionType,
int row,
int column
)
Public Function GetCellText (
sectionType As SectionType,
row As Integer,
column As Integer
) As String
public:
String^ GetCellText(
SectionType sectionType,
int row,
int column
)
member GetCellText :
sectionType : SectionType *
row : int *
column : int -> string
Parameters
- sectionType SectionType
-
The requested section type
- row Int32
-
Row Number in the Section
- column Int32
-
Column Number in the Section
Return Value
String
The text for the given cell
ExceptionsException | Condition |
---|
ArgumentException |
The sectionType is not a valid type for this view.
|
ArgumentOutOfRangeException |
The given row number row is invalid.
-or-
The given column number column is invalid.
-or-
A value passed for an enumeration argument is not a member of that enumeration
|
See Also