RebarShapeDrivenAccessorSetLayoutAsMinimumClearSpacing Method

Sets the Layout Rule property of rebar set to MinimumClearSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLayoutAsMinimumClearSpacing(
	double spacing,
	double arrayLength,
	bool barsOnNormalSide,
	bool includeFirstBar,
	bool includeLastBar
)

Parameters

spacing  Double
The maximum spacing between rebar in rebar set
arrayLength  Double
The distribution length of rebar set
barsOnNormalSide  Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar  Boolean
Identifies if the first bar in rebar set is shown
includeLastBar  Boolean
Identifies if the last bar in rebar set is shown
Exceptions
ExceptionCondition
ArgumentOutOfRangeException The spacing isn't bigger than 0.0. -or- the set length arrayLength isn't acceptable.
InapplicableDataException This RebarShapeDrivenAccessor is an instance of a spiral or multiplanar shape.
InvalidOperationException This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.
Remarks
When changing the layout rule to MinimumClearSpacing, you must also simultaneously set Spacing, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
See Also