HVACLoadSpaceTypeCreate Method |
Creates a space type.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static HVACLoadSpaceType Create(
Document document,
string name
)
Public Shared Function Create (
document As Document,
name As String
) As HVACLoadSpaceType
public:
static HVACLoadSpaceType^ Create(
Document^ document,
String^ name
)
static member Create :
document : Document *
name : string -> HVACLoadSpaceType
Parameters
- document Document
-
The document.
- name String
-
The space type name.
Return Value
HVACLoadSpaceType
The new space type.
ExceptionsException | Condition |
---|
ArgumentException |
name is an empty string or contains only whitespace.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
The given value for name is already in use as a space type name.
|
ArgumentNullException |
A non-optional argument was null
|
See Also