DocumentConvertSymbolicToModelCurves Method

Converts a group of SymbolicCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ModelCurveArray ConvertSymbolicToModelCurves(
	View view,
	SymbolicCurveArray symbolicCurve
)

Parameters

view  View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
symbolicCurve  SymbolicCurveArray
The symbolic curve array to be converted.

Return Value

ModelCurveArray
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument is .
InvalidOperationException Thrown when one or more curves could not be successfully converted.
Remarks
This operation will create new ModelCurves with the symbolicCurves' geometry curves and delete the SymbolicCurve in the array.
See Also