BuildingOperatingDayScheduleGetValueForHour Method |
Gets the usage value for an hour.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetValueForHour(
int hour
)
Public Function GetValueForHour (
hour As Integer
) As Double
public:
double GetValueForHour(
int hour
)
member GetValueForHour :
hour : int -> float
Parameters
- hour Int32
-
The hour in the day, as an integer. For example: 0 is 12:00 midnight to 1:00 am, 6 is 6:00 am to 7:00 am, 12 is 12:00 noon to 1:00 pm, and 23 is 11:00 pm to midnight.
To avoid issues around daylight savings times, these hours represent 1/24 of an earth rotation, and will not be exactly 60 minutes.
Return Value
Double
The usage as a fraction between 0 and 1 inclusive. For example: 0 in a lighting schedule means all lights are off, .5 means half of lights are on, 1 means all lights are on.
Exceptions
See Also