PostableCommand Enumeration

Enumerates all of the built-in commands which can be posted by an API application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum PostableCommand
Members
Member nameValueDescription
RoofByFace20 Creates an element using a non-vertical face of a mass.
Soffit493 Creates a roof soffit in the building model.
LoadAsGroupIntoOpenProjects786 Loads the current project as a group into another open project or family.
LoadIntoProject791 Loads the rebar shape into open projects or family files.
RepeatComponent840 Repeats the selected applied component along a divide path or surface.
ConnectionSettings996 Opens the Structural Connections Settings dialog in which you can load and unload add-in connections into Revit. If no add-ins are present, no connections are available in the Connections tab.
StructuralConnection997 Adds a structural connection to structural elements.
ShowWarningsInViews1,000 Select to show structural connection warning marks in your project views. Deselect to hide warning marks.
ViewList1,075 Creates a schedule of the views in the project.
LinearDimensionTypes1,081 Defines attributes for linear (horizontal and vertical) dimensions.
AngularDimensionTypes1,082 Defines attributes for angular dimensions.
SplitElement1,100 Cuts an element into separate individual elements.
SpotElevation1,109 Displays the elevation of a selected point.
SpotCoordinate1,114 Displays the North/South and East/West coordinates of points in a project.
AlignmentStation1,115 Add an individual alignment station annotation.
AlignmentStationSet1,116 Add a series of alignment station annotations.
RoofByFootprint1,142 Creates a roof using the building footprint to define its boundaries.
RoofByExtrusion1,143 Creates a roof by extruding a profile that you sketch.
RadialDimensionTypes1,199 Defines attributes for radial dimensions.
ReloadLatest1,729 Loads updates from the central model to your local copy of the project.
Render1,782 Creates a photorealistic image of a building model.
ShowHistory1,985 Displays a list of all the times a workshared file (the central model or a local copy of the central model) was saved and who saved it.
GrayInactiveWorksets2,765 Displays elements in inactive worksets as gray to visually distinguish them from elements in active worksets.
DrawOnFace3,096 Draws lines on existing surfaces.
DrawOnWorkPlane3,097 Draws lines on the active work plane.
ImportGBXML3,102 Imports analysis data from a gbXML file.
ExportReportsRoomOrAreaReport3,125 Saves a schedule or Room/Area report.
SheetIssuesOrRevisions3,153 Specifies revision information for the project.
RevisionSchedule3,154 Adds a revision schedule to a custom title block.
CalloutTags3,167 Specifies the callout head for callout tags, and the radius of the callout bubble.
ElevationTags3,168 Defines properties for elevation tags.
SectionTags3,169 Specifies the shape of heads and tails for section tags.
FloorByFaceFloor3,234 Converts a mass floor into a floor of the building model.
HideCategory3,240 Hides all elements that belong to a selected category in the current view.
RunInterferenceCheck3,259 Locates invalid intersections between elements in a project.
SpecifyCoordinatesAtPoint3,266 Relocates a model and rotates the model to True North by specifying coordinates for North/South, East/West, and Elevation.
ExportIFC3,278 Saves an IFC file.
SystemBrowser3,280 Displays the System Browser. Displays a hierarchical list of all the components in each discipline in a project, either by system or by zone.
ExportCADFormatsSTEP3,340 Creates DWG, DXF, DGN, OBJ, SAT, STL or STEP files.
ExportDWFOrDWFx3,341 Creates DWF or DWFx files.
ExportCADFormatsDWG3,342 Creates DWG, DXF, DGN, OBJ, SAT, STL or STEP files.
ExportCADFormatsDXF3,343 Creates DWG, DXF, DGN, OBJ, SAT, STL or STEP files.
ExportCADFormatsDGN3,344 Creates DWG, DXF, DGN, OBJ, SAT, STL or STEP files.
ExportCADFormatsACIS_SAT3,345 Creates DWG, DXF, DGN, OBJ, SAT, STL or STEP files.
ExportPDF3,346 Creates PDF files.
ExportCADFormatsSTL3,347 Creates DWG, DXF, DGN, OBJ, SAT, STL or STEP files.
ExportCADFormatsOBJ3,348 Creates DWG, DXF, DGN, OBJ, SAT, STL or STEP files.
OpenIFC3,355 Opens an IFC file.
RelinquishAllMine3,363 Releases ownership of worksets and borrowed elements that have not been changed.
MaterialTakeoff3,388 Creates a list of the sub-components or materials of any Revit family category.
DWFMarkup3,401 Links marked-up DWF files into a Revit project so you can see the markups on corresponding sheets.
ImportTypes3,404 Imports family types from a text (.txt) file into the current family.
ExportExportTypes3,405 Exports family types from the current family to a text (.txt) file.
OpenIFCOptions3,409 Sets options for the IFC template and class mapping.
KeynoteLegend3,449 Creates a list of the keynotes used in a project, and their definitions.
KeynotingSettings3,450 Specifies the location of the keynote table and the numbering method for keynotes.
Web3,619 Draws the web elements between the chords.
TopChord3,620 Draws the top chord of the truss family.
BottomChord3,621 Draws the bottom chord of the truss family.
ShapeStatus3,640 When enabled, this button indicates that the rebar shape is not valid.
TogglePropertiesPalette4,534 Displays or hides a palette where you can view and edit instance properties.
StatusBarWorksets4,609 For a workshared project, displays the active workset and the number of Others' pending Editing Requests in the status bar.
StatusBarDesignOptions4,610 Displays the active design option in the status bar.
ReinforcementNumbers4,700 Defines or edits numbering sequences by partition for rebar and fabric sheets.
FamilyCategoryAndParameters10,133 Assigns the properties of a predefined family category to the component you are creating.
ExportImagesandAnimationsWalkthrough12,059 Saves animations or image files.
ExportImagesandAnimationsSolarStudy12,075 Saves animations or image files.
SunSettings12,299 Specifies the location of the sun for solar studies, walkthroughs, and rendered images.
Grid32,770 Places column grid lines in the building design.
ArchitecturalWall32,771 Creates a non-structural wall in the building model.
Door32,772 Adds doors to the building model.
Window32,773 Adds windows to the building model.
Delete32,778 Removes selected elements from the building model.
Space32,784 Places analytical spaces to account for the entire volume within the model. This includes rooms, plenums and chases.
SpaceTag32,785 Labels spaces in a project.
SpaceSeparator32,786 Draws a space separation line to divide space.
TypeProperties32,790 Displays properties for the family type to which the selected element belongs.
Level32,794 Adds a level to the model.
FramingElevation32,814 Creates a framing elevation to show vertical bracing.
ArchitecturalFloor32,914 Creates a floor for the current level of the building model.
Stair32,916 Adds a stair to the building model by creating common run, landing, and support components.
ArchitecturalColumn32,918 Adds architectural columns to the building model.
MirrorProject32,919 Flips the position of a project around a selected axis.
RotateProjectNorth32,920 Changes the relationship of elements relative to Project North (the top of the drawing area) in plan views.
Rotate32,934 Rotates selected elements around an axis.
MirrorPickAxis32,936 Reverses the position of selected elements, using an existing line or edge as the mirror axis.
LineWeights32,946 Creates or modifies line weights.
ObjectStyles32,947 Specifies line weights, colors, and patterns, and materials for model objects, annotation objects, and imported objects.
AnalysisDisplayStyles32,948 Specifies a presentation format for visualizing analysis results.
Snaps32,949 Specifies snap increments, and enables or disables snap points.
ProjectUnits32,950 Specifies the display format for units of measure.
StructuralPlan32,952 Creates a structural plan view.
FloorPlan32,953 Creates a floor plan view.
Section32,955 Creates a section view.
Camera32,956 Creates a 3D view from the perspective of a camera placed in the view.
ProjectBrowser32,957 Displays the Project Browser.
NewSheet32,958 Creates a page for a document set.
ImportCAD32,959 Imports data or 3D geometry from other CAD programs to a Revit model or family.
LinkCAD32,961 Links a CAD file to the current Revit project.
PointCloud32,963 Links a Point Cloud file (*.rcp or *.rcs) into the current project.
NewFamily32,983 Creates a set of custom components to use in projects.
LoadShapes32,984 Loads a Revit family into the current file.
NewConceptualMass32,986 Opens a template for creating a conceptual massing model.
LoadAutodeskFamily32,990 Load an Autodesk family from the cloud.
Pin32,997 Locks a model element in place.
Walkthrough33,000 Creates an animated 3D walkthrough of a model.
Unpin33,001 Unlocks a model element so it can move.
SolidExtrusion33,002 Creates a 3D solid by extruding a 2D shape (profile).
PlaceAComponent33,003 Places an element in the building model, based on a selected element type.
ModelLine33,006 Creates a line that exists in 3D space and is visible in all views of a project.
StairPath33,010 Annotates the slope direction and walk line of a stair.
ReferencePlane33,026 Creates a reference plane using drawing tools.
Redo33,031 Reverses the effects of the previous UNDO command
Undo33,032 Reverses the most recent action
Control33,034 Adds a flip arrow to the view.
PickAPlane33,078 Select a plane in the view to define a new workplane.
Filters33,099 Creates a filter to modify the visibility and graphics of elements in views based on element parameters.
TemporaryDimensions33,100 Specifies the placement and component references for temporary dimensions.
LinePatterns33,120 Creates or modifies line patterns.
Array33,121 Creates a linear or radial array of selected elements.
Move33,127 Moves selected elements to the specified location in the current view.
Copy33,129 Copies selected elements and places them in the specified location in the current view.
PlaceView33,132 Adds a view to a sheet.
Text33,134 Adds text annotations (notes) to the current view.
NewTitleBlock33,140 Opens a template for creating a Title Block family.
AutomaticCeiling33,158 Creates a ceiling at a specified distance above the level in which it resides.
FillPatterns33,163 Creates or modifies drafting patterns and model patterns.
Default3DView33,169 Opens the default orthographic 3D view.
Label33,174 Creates a label for the annotation symbol.
VisibilityOrGraphics33,175 Overrides the default visibility and graphic display of model elements and annotations in the current view.
Opening33,177 Creates an opening in a host, such as a wall or ceiling.
NewProject33,179 Creates a Revit project file.
ActivateView33,181 Enables you to modify the selected view without leaving the sheet.
Materials33,184 Specifies the materials and associated properties to apply to model elements or families.
DeactivateView33,185 Deactivates the view, so you can no longer change the view from the sheet.
MaterialAssets33,186 Modifies the assets that define a material.
DecalTypes33,188 Creates a decal that you can use to place images on surfaces of a building model for rendering.
Options33,195 Display Revit Options Dialog.
Room33,198 Creates a room bounded by model elements (such as walls, floors, and ceilings) and separation lines.
CurtainGrid33,199 Creates a grid line in a curtain wall or curtain system.
CurtainWallMullion33,200 Creates a horizontal or vertical mullion on a curtain grid.
FamilyTypes33,203 Allows you to enter parameter values for existing family types, add parameters to the family, or create new types within the family.
FilledRegion33,204 Creates a 2D, view-specific graphic with a fill pattern and a boundary line.
RoomTag33,208 Tags the selected room.
Align33,218 Aligns one or more elements with a selected element.
Symbol33,221 Places a 2D annotation drawing symbol in the current view.
DuplicateView33,245 Creates a view that contains only the model geometry from the current view.
ExportOptionsExportSetupsDGN33,248 Sets export options for CAD and IFC.
ExportOptionsExportSetupsDWGOrDXF33,251 Sets export options for CAD and IFC.
ColorFillLegend33,252 Places a legend in a view to indicate the meanings of color fills for rooms or areas.
BuildingElevation33,255 Creates an elevation view.
JoinOrUnjoinRoof33,277 Connects roofs to other roofs or walls, or reverses a previous join.
SolidBlend33,278 Creates a solid 3D shape that changes along its length, blending from a starting shape to an ending shape.
ManageLinks33,279 Provides options for managing linked files to building models.
SolidRevolve33,287 Creates a 3D shape by sweeping a 2D profile around an axis.
ScheduleOrQuantities33,296 Creates a key schedule or a schedule of building components.
Callout33,298 Creates a rectangular callout in the view.
SolidSweep33,300 Creates a 3D shape by sweeping a 2D profile along a path.
CreateGroup33,305 Creates a group of elements for easy reuse.
Ramp33,316 Adds a ramp to the building model.
RoomSeparator33,318 Creates a separation line to bound rooms where no walls or other room-bounding elements exist.
AlignedToCurrentView33,320 Pastes elements that were cut or copied from another view into the current view.
AlignedToPickedLevel33,321 Pastes the selected elements into a elevation view or a section view.
WallJoins33,323 Changes how walls join together (butt, miter, square off).
StartingView33,327 Specifies the view that first displays when you open the model.
AlignedToSelectedLevels33,328 Pastes multiple elements from one level to specified levels.
TagByCategory33,329 Attaches a tag to an element based on the element category.
AlignedToSelectedViews33,332 Pastes selected elements, including view-specific elements such as dimensions, into specified views.
LoadedTagsAndSymbols33,338 Lists the tags and symbols that will be used for each element category.
NewAnnotationSymbol33,339 Creates a tag or symbol to identify elements in the project.
AlignedToSamePlace33,341 Pastes the elements to the same place from which they were cut or copied.
SpotSlopeTypes33,348 Defines attributes for spot slopes.
Arrowheads33,349 Specifies line weights, fills, and styles for annotation arrowheads.
SpotElevationTypes33,350 Defines attributes for spot elevations.
SpotCoordinateTypes33,351 Defines attributes for spot coordinates.
ReviewWarnings33,352 Displays a list of messages that you can ignore or resolve.
AlignmentStationLabelTypes33,354 Defines attributes for Alignment Station Labels.
LineStyles33,360 Creates or modifies line styles.
ReflectedCeilingPlan33,380 Creates a reflected ceiling plan view.
DetailLevel33,384 Specifies the detail level (coarse, medium, or fine) that applies to each view scale by default.
VoidExtrusion33,397 Creates a 3D shape that is then used to remove part of a solid 3D shape.
VoidBlend33,398 Creates a 3D blend, which is then used to remove part of a solid 3D shape.
VoidRevolve33,399 Creates a 3D shape by sweeping a 2D profile around an axis, and uses the 3D shape to remove part of a solid 3D shape.
VoidSweep33,400 Creates a 3D shape by sweeping a 2D profile along a path, and uses the resulting 3D shape to remove part of a solid 3D shape.
CutGeometry33,407 Selects the geometry to cut.
UncutGeometry33,408 Selects which geometry does not get cut when you join geometry.
PlaceDetailGroup33,421 Places an instance of a detail group in the view.
OverrideByCategory33,422 Changes the graphic display settings for all elements that belong to the same category as the selected element in the current view.
DetailComponent33,424 Adds a view-specific detail component to a view.
DetailLine33,425 Creates view-specific lines.
Insulation33,432 Places a batt insulation graphic in a detail view.
CreateSimilar33,441 Places an element of the same type as the selected element
Worksets33,460 Creates worksets and adds elements to them.
Phases33,472 Specifies project phases, phase filters, and graphic overrides for phases.
PropertyLine33,480 Creates a property line in a plan view.
ImportImage33,499 Imports a raster image into a Revit project to use as a background image or visual aid during the creation or presentation of the model.
ImportPDF33,503 Inserts a PDF file into a model view to use as a background image or visual aid.
MatchTypeProperties33,513 Converts one or more elements to match the type of another element in the same view.
ScopeBox33,519 Controls the visibility of datum elements (grids, levels, and reference planes) in specific views.
Linework33,520 Overrides the line style for a selected line in the active view only.
SetWorkPlane33,527 Specifies the work plane for the current view or for a selected work-plane-based element.
DraftingView33,530 Creates a view showing details that are not directly associated with the building model.
Legend33,531 Creates a list of building components and annotations used in a project.
Demolish33,534 Marks elements as demolished in the current phase.
RevisionCloud33,540 Adds a revision cloud to the current view or sheet to indicate design areas that have changed.
SynchronizeAndModifySettings33,542 Allows you to specify options for the synchronization operation.
ProjectInformation33,543 Specifies basic information about the project, including the project status and client information.
ModelInPlace33,544 Creates a component that is unique to the project.
SheetList33,631 Creates a schedule that lists the drawings in the project.
AreaPlan33,638 Creates an area plan view.
GradedRegion33,640 Modifies topography to indicate changes during the construction process.
ManageImages33,648 Lists all raster images used in the project.
ApplyTemplatePropertiesToCurrentView33,651 Applies properties stored in a view template to the current view.
RevealWall33,654 Extrudes a profile along a path to create a cutout in a wall.
SweepWall33,655 Creates a wall sweep by extruding a profile along a path.
Paint33,656 Applies a material to the face of an element.
RemovePaint33,657 Removes paint from selected faces.
NoteBlock33,659 Creates a schedule of annotations added using the Symbol tool.
ModelText33,660 Adds 3D text to the building model.
ShowHiddenLinesByElement33,671 Displays hidden lines for individual model elements and detail elements that are obscured by other elements in the current view.
RemoveHiddenLinesByElement33,673 Removes hidden lines for model elements and detail elements that are obscured by other elements in the active view only.
ManageViewTemplates33,683 Displays parameters for view templates in the project.
CreateTemplateFromCurrentView33,684 Creates a view template using the properties of the current view as the basis for the new template.
SplitFace33,689 Divides the face of an element (such as a wall or floor) into regions for the application of different materials.
RestoreBackup33,690 Rolls back changes made to a workshared project, or saves a selected backup version to be the current working model.
ExportODBCDatabase33,693 Saves model data to an ODBC database.
LoadAsGroup33,695 Loads a Revit file as a group.
SaveAsLibraryGroup33,696 Saves a copy of all loaded families, the selected family, group, or view to your library.
ParkingComponent33,698 Adds parking spaces to a topography.
TransferProjectStandards33,699 Copies selected project settings from another open project to the current project.
SymbolicLine33,700 Creates lines that are meant for symbolic purposes only, and are not part of the actual geometry of the component or building model.
CutProfile33,709 Changes the shape of elements that are cut in a view, such as roofs, walls, floors, and the layers of compound structures.
ExportReportsSchedule33,710 Saves a schedule or Room/Area report.
CloseInactiveViews33,712 Closes open views except for the currently active view. The current view remains open in the drawing area.
AreaTag33,718 Tags the selected area.
AreaBoundary33,719 Defines boundaries for areas.
Area33,720 Creates an area defined by walls and boundary lines.
JoinGeometry33,729 Creates clean joins between 2 or more host elements that share a common face, such as walls and floors.
UnjoinGeometry33,730 Removes a join between 2 or more elements.
SwitchJoinOrder33,731 Changes the order in which elements join with one another.
TagAllNotTagged33,735 Adds tags to multiple elements in one step.
SharedParameters33,748 Specifies parameters that can be used in multiple families and projects.
LegendComponent33,751 Adds a graphic representation of a selected model element to a legend view.
Offset33,757 Copies or moves a selected element (such as a line, wall, or beam) a specified distance perpendicular to its length.
PurgeUnused33,780 Removes unused families and types from a project.
PlaceDecal33,789 Places an image on surfaces of a building model for rendering.
TitleBlock33,806 Creates a title block element in a sheet view.
RebarLine33,810 Defines lines and geometry of the rebar shape.
LabelContours33,820 Displays the elevations of contour lines.
SplitWithGap33,829 Splits a wall, pipe, duct, cable tray, conduit, structural framing or a column into 2 segments with a defined gap.
ThinLines33,834 Displays all lines on screen as a single width, regardless of zoom level.
LinkRevit33,836 Links another Revit model to the current model.
ExportImagesandAnimationsImage33,838 Saves animations or image files.
ProjectParameters33,855 Specifies parameters that can be added to categories of elements in a project, and used in schedules.
RelocateProject33,856 Moves the model relative to the shared coordinate system.
RotateTrueNorth33,857 Changes the angle for a project relative to True North.
DuplicateWithDetailing33,858 Creates a view that includes model geometry and view-specific elements from the current view.
Location33,862 Specifies the geographic location for the project.
AcquireCoordinates33,863 Determines the coordinates used in a linked project, and uses them for the current project.
ReportSharedCoordinates33,865 Displays shared coordinates of a linked model within a host model.
IdsOfSelection33,866 Displays unique identifiers for the selected elements.
SelectById33,867 Uses an element's unique identifier to locate and select the element in the current view.
PublishCoordinates33,869 Determines the coordinates used in the current model, and uses them for a linked model.
ParametersService33,870 Use the Parameters Service to manage shared parameters and import them into a Revit session.
PlanRegion33,900 Creates a plan region within a view.
BrowserOrganization33,904 Changes the way that views are listed in the Project Browser.
Matchline33,905 Adds matchlines to indicate where a view is split.
ViewReference33,906 Adds an annotation indicating the sheet number and detail number for a selected view.
DesignOptions33,907 Creates and manages design option sets and individual design options for the project.
AddToSet33,908 Moves selected elements from the main model to one or more design options in a set.
PickToEdit33,910 Opens a design option for editing by selecting an element contained in the option.
EditingRequests33,911 Displays a list of other users' requests to borrow elements in your worksets, and your pending requests.
SaveAsLibraryFamily33,923 Saves a copy of all loaded families, the selected family, group, or view to your library.
Railing34,969 Creates a railing by sketching the railing path.
Beam34,972 Adds individual beams, a chain of beams, or beams along grid lines.
Brace34,973 Adds diagonal structural members connected to beams and columns.
StructuralColumn34,974 Adds a vertical load-bearing element to the building model.
StructuralWall34,975 Creates a load-bearing or shear wall in the building model.
SpanDirectionSymbol34,980 Places a span direction symbol on a structural floor.
StructuralFloor34,985 Creates a structural floor (slab) for the current level of the building model.
Scale34,986 Resizes the selected item.
StructuralSettings34,993 Defines settings for analytical elements and the display of structural framing.
ReferenceLine34,994 Creates a reference line that you can use when creating a new family, or to create constraints for the family.
RebarCoverSettings35,003 Adds, removes, or modifies the default rebar cover settings.
ShowMassFormAndFloors35,060 Displays mass forms and any mass floors you have specified in all views.
CurtainSystemByFace35,072 Creates a curtain system on the face of a mass or generic model.
WallByFaceWall35,074 Creates walls using faces of a mass or generic model.
ShowMassByViewSettings35,075 Displays masses based on the settings for the current view. By default, masses are turned off.
ShowMassSurfaceTypes35,078 Displays mass faces, including any glazing and shades that have been specified.
ShowMassZonesAndShades35,079 Displays mass zones, glazing, and shades if they have been specified.
StructuralRebar35,098 Places planar, multi-planar or free form rebar.
CopyMonitorUseCurrentProject35,107 Monitors grids, levels, columns, walls, floors, and openings within the current project.
CopyMonitorSelectLink35,108 Copies selected elements from a linked project to the host project, and monitors changes to these elements.
CoordinationReviewUseCurrentProject35,110 Displays warnings for monitored elements in the current project.
CoordinationSelectLink35,111 Displays warnings for monitored elements between linked projects and the host project.
Wall35,113 Creates foundations hosted by walls.
Isolated35,114 Adds footings or pile caps to the building model.
MaterialTag35,145 Tags a selected element using the description specified for its material.
CoordinationSettings35,149 Specifies mapping behavior when copying MEP fixtures from a linked model into the current project.
Slab35,156 Adds a foundation slab to the building model.
ElementKeynote35,158 Tags a selected element using the keynote specified for the element type.
MaterialKeynote35,159 Tags a selected element using the keynote specified for its material.
UserKeynote35,160 Tags an element with a keynote that you select.
LoadSelection35,180 Loads a previously saved selection set.
SaveSelection35,181 Saves the currently selected elements as a set.
EditSelection35,183 Edits a previously saved selection set.
ActivateControlsAndDimensions35,194 Enable or disable the visibility of pins, constraints, and temporary dimensions when multiple elements are selected.
ShowWorksharingMakeEditableControls35,195 Enables/Disables display of "Make Editable" controls when elements are selected.
MultiCategoryTag35,203 Attaches tags to elements of multiple categories, based on a shared parameter.
BoundaryConditions35,223 Defines point, line, and area boundary conditions in an analytical model.
StructuralPathReinforcement35,225 Sketches the path of evenly placed reinforcing bars that are created perpendicular to the sketch.
PathReinforcementSymbol35,228 Places a symbol that shows extents and hook types for the selected path reinforcement.
OpeningByFace35,253 Creates an opening that is perpendicular to the selected face of a roof, floor, or ceiling.
VerticalOpening35,254 Cuts a vertical opening through a roof, floor, or ceiling.
DormerOpening35,255 Cuts a roof to create an opening for a dormer.
WallOpening35,256 Cuts a rectangular opening in a straight or curved wall.
ShaftOpening35,257 Creates a vertical opening that spans multiple levels, cutting through intervening roofs, floors, and ceilings.
SpotSlope35,259 Displays the slope at a specific point on a face or an edge of a model element.
HideElements35,261 Hides selected elements in the current view.
ToggleRevealHiddenElementsMode35,263 Toggle reveal hidden elements mode.
OverrideByElement35,265 Changes the graphic display settings for selected elements in the current view.
OverrideByFilter35,266 Changes the graphic display settings for all elements in the view that meet the criteria specified in a filter.
DuplicateAsDependent35,280 Creates a view that is dependent on the original view.
MaskingRegion35,287 Creates a graphic that obscures elements in a project or family.
MajorSegment35,293 Identifies one segment of the rebar shape that maintains its general position in rotation and auto-expansion behaviors.
ReinforcementSettings35,300 Customizes reinforcement settings such as rounding parameters, rebar hosting and abbreviations of area/path reinforcement tagging.
ExportFBX35,350 Saves a 3D view as an FBX file.
OpenFamily35,365 Opens a Revit family.
CreateParts35,425 Creates parts from the layers or subcomponents of a selected element.
ViewCube35,458 Shows or hides the ViewCube, which allows you to change the orientation of a 3D view.
BeamAnnotations35,585 Places multiple beam tags, annotations, and spot elevations.
AllowableBarTypes35,599 Defines the allowable rebar types (diameters) of the shape type.
MacroManager35,602 Opens the Macro Manager to run, create, or delete a macro.
MacroSecurity35,603 Specifies the default security settings for macros in the Revit application.
NavigationBar35,631 Shows or hides the navigation bar, which provides access to the ViewCube, SteeringWheels, and zoom/pan functions.
FormWorkPlaneView35,703 Enables the Workplane Viewer.
ReconcileHosting35,708 Lists tags and elements hosted by the linked model that require review, due to changes in the linked model.
DiameterDimension35,778 Places a dimension that measures the diameter of an arc or circle.
DiameterDimensionTypes35,779 Defines attributes for diameter dimensions.
StructuralFabricArea35,781 Located on the Reinforcement panel of the Structure tab (or Modify tab for floors, walls and foundation slabs).Sketches the boundary of a fabric area to populate with fabric sheets.
FabricReinforcementSymbol35,793 Located on the Symbol panel of the Annotate tab.Places a symbol that represents the fabric sheet.
PlaceOnStairOrRamp35,807 Places a railing on a stair or ramp.
DuctPressureLossReport35,811 Generates a pressure loss report for one or more duct systems.
PipePressureLossReport35,812 Generates a pressure loss report for one or more pipe systems.
OpenSampleFiles35,815 Opens a Revit sample file.
SingleFabricSheetPlacement35,823 Places a single fabric sheet on floors, walls, and foundation slabs.
AlignedMultiRebarAnnotation35,831 Tags multiple elements with a single annotation that displays aligned dimensions between references as well as parameters from the referenced elements. For example, all rebar in a rebar set can be referenced with a single tag.
LinearMultiRebarAnnotation35,832 Tags multiple elements with a single annotation that displays linear dimensions between references as well as parameters from the referenced elements. For example, all rebar in a rebar set can be referenced with a single tag.
FabricationSettings35,839 Opens the Fabrication Settings dialog.
LinkIFC35,853 Links an IFC file to the current project to reference its information for additional design work.
SelectionBox35,857 Isolates selected elements in the current view (if a 3D isometric view) or the default 3D view.
InsertCoupler35,862 Places a reinforcement coupler element to join rebar in a host.
PAndIDModeler35,882 Create a 3D piping model directly from a 2D P&ID drawing in the cloud.
PAndIDSettings35,883 Manage the mappings between elements, such as services and families, between the P&ID drawing and the Revit model.
TogglePAndIDModelerBrowser35,884 Toggle P&ID Modeler browser.
DuctAccessory37,004 Places a duct accessory. These accessories include dampers, filters and smoke detectors.
AirTerminal37,005 Places a register, grille, or diffuser.
Duct37,006 Draws rigid round, rectangular, or oval ductwork.
MechanicalEquipment37,008 Places mechanical equipment such as boilers, furnaces, or fans.
DuctFitting37,009 Places a duct fitting. These fittings include elbows, tees, wyes, crosses, and other types of fittings.
FlexDuct37,010 Draws round and rectangular flexible ductwork.
ConvertToFlexDuct37,014 Changes a length of ductwork connected to an air terminal from rigid duct to flexible duct.
DuctLegend37,027 Places a legend to indicate the color fills associated with ductwork in duct systems.
PanelSchedules37,053 Generates a panel schedule for a specified panel.
ElectricalSettings37,054 Opens the Electrical Settings dialog to define distribution systems, wire types, cable tray and conduit sizes, and demand factors.
LoadClassifications37,055 Assigns and specifies demand factors to a load classification.
LightingFixture37,059 Places lighting fixtures such as ceiling, wall, and recessed lights.
ElectricalEquipment37,060 Places electrical equipment such as panels and switch gear.
ElectricalFixture37,061 Places electrical devices such as receptacles, junction boxes, and other power devices.
CheckCircuits37,062 Verifies all circuits for proper connections to panels and valid system assignments. Errors are reported in a warning dialog.
DemandFactors37,068 Applies demand factors to a panel.
Pipe37,100 Draws rigid piping.
FlexPipe37,102 Draws flexible piping.
PipeFitting37,103 Places a pipe fitting. These fittings include elbows, tees, wyes, crosses, unions, and other types of fittings.
PipeAccessory37,105 Places a pipe accessory. These accessories include connectors, valves, and inline water heaters.
ArcWire37,106 Draws arced wire runs.
PipeLegend37,149 Places a legend to indicate the color fills associated with piping systems.
CheckPipeSystems37,155 Verifies all pipe systems for properly connected pipes and valid system assignments.
CheckDuctSystems37,167 Verifies all duct systems for properly connected ductwork and valid system assignments.
MechanicalSettings37,168 Opens the Mechanical Settings dialog.
PlumbingFixture37,203 Places plumbing fixtures. These fixtures include sinks, water closets, tubs, drains, and various appliances.
Sprinkler37,206 Places a sprinkler.
ElectricalConnector37,217 Adds an electrical connector to a component.
DuctConnector37,218 Adds a duct connector to a component.
PipeConnector37,219 Adds a pipe connector to a component.
Zone37,244 Defines HVAC zones within a project.
BuildingOrSpaceTypeSettings37,259 Opens the Building and Space Type Settings dialog to manage building and space parameters and schedules.
ChamferedWire37,260 Draws chamfered wire runs.
SplineWire37,261 Draws splined wire runs.
Communication37,278 Places communication devices such as intercom system components.
Data37,279 Places data devices such as ethernet and other network connections.
FireAlarm37,280 Places fire alarm devices such as smoke detectors, manual pull stations, and annunciators.
Lighting37,281 Places lighting switches such as daylight sensors, occupancy sensors, and manual switches.
NurseCall37,282 Places nurse call devices such as call stations, code blue stations, and door lights.
Security37,283 Places security devices such as door locks, motion sensors, and surveillance cameras.
Telephone37,284 Places a telephone jack.
CableTrayConnector37,291 Adds a cable tray connector to a component.
ConduitConnector37,292 Adds a conduit connector to a component.
CableTrayFitting37,295 Places a cable tray fitting. These fittings include elbows, tees, wyes, crosses, and other unions.
ConduitFitting37,296 Places a conduit fitting. These fittings include elbows, tees, wyes, crosses, and other unions.
CableTray37,297 Draws cable tray runs such as rigid ladder or channel cable tray.
Conduit37,298 Draws rigid conduit runs.
ManageTemplates37,314 Manages and applies panel schedule templates to existing schedules in the project.
EditATemplate37,315 Modifies a specific panel schedule template.
ParallelConduits37,361 Creates parallel runs of conduit based on an initial conduit run.
DuctPlaceholder37,427 Draws placeholder duct without elbow or tee fittings.
PipePlaceholder37,428 Draws placeholder pipe without elbow or tee fittings.
ParallelPipes37,441 Creates parallel runs of pipe based on an initial pipe run.
ShowDisconnects37,444 Controls the display of graphical disconnect warnings for duct, pipe, conduit, cable tray, electrical circuits, and fabrication hangers.
MultiPointRouting37,574 Automatically build a run of connected MEP fabrication parts by clicking points in the model.
SystemZone37,617 Create a system-zone for analytical spaces.
SiteComponent40,239 Adds site-specific elements, such as trees, parking islands, and fire hydrants.
AreaAndVolumeComputations40,382 Specifies how areas and volumes are calculated, and creates area schemes.
ShowWorkPlane40,484 Displays or hides the active work plane in the view.
Fascia40,601 Adds fascia to the edge of a roof, soffit, or other fascia, or to model lines.
Gutter40,602 Adds a gutter to the edge of a roof, soffit, or fascia, or to model lines.
SlabEdgeFloor40,603 Shapes the horizontal edge of a floor slab.
CheckSpelling40,986 Checks the spelling of text notes in a selection or in the current view or sheet.
RepeatingDetailComponent42,058 Repeats a detail component along a path.
InsertViewsFromFile42,309 Copies specified views (sheets, schedules, or drafting views) from a project file and saves them in the current project.
Insert2DElementsFromFile42,310 Copies 2D elements from a detail view (saved in another project) into a detail view in the current project.
SaveAsLibraryView42,312 Saves a copy of all loaded families, the selected family, group, or view to your library.
AutomaticBeamSystem42,398 Creates a layout that is used to control the number and spacing of a series of parallel beams.
PlaceMass42,644 Places an instance of a mass family in the project.
InPlaceMass42,645 Creates a mass that is unique to the project.
SynchronizeNow42,654 Updates a local copy of a workshared project using settings from the Synchronize with Central dialog.
StructuralTrusses43,213 Adds a truss to the structure model.
CreateAnAreaBasedLoad43,641 Creates an area based load from the area defined by the area based load boundaries.
AreaBasedLoadBoundary43,647 Places a boundary line for electrical area based loads.
EquipmentLoad43,648 Opens the System Browser to define equipment loads, such as a chiller or other specific equipment.
MEPFabricationDuctworkStiffener43,659 Places a stiffener on fabrication ductwork.
ShowBoundaryOpenEnds45,665 Displays dots on the open ends of area based load boundary lines.
MechanicalControlDevice45,673 Places a mechanical control device such as thermostats, CO2 sensors, and humidistats.
PlumbingEquipment45,674 Places plumbing equipment such as hot water heaters, domestic water pumps, and sewage pumps.
HideBoundaryOpenEnds45,676 Hides dots that display on the open ends of area based load boundary lines.
ShowLastReport46,061 Displays the most recent interference check report.
GraphicalColumnSchedule46,139 Creates a graphical column schedule for the project.
ApplyCoping46,450 Adds coping to steel beams and columns.
RemoveCoping46,451 Removes coping from steel beams and columns.
BeamSystemSymbol46,567 Places a beam system span tag.
StructuralAreaReinforcement46,932 Sketches the boundary of an area to populate with rebar.
AreaReinforcementSymbol46,959 Places a symbol that shows extents and hook types for the selected area reinforcement.
SolidSweptBlend47,163 Creates a blend that sweeps along a defined path.
VoidSweptBlend47,164 Creates a blend that sweeps along a defined path, and uses the resulting 3D shape to remove part of a solid 3D shape.
EditRebarCover48,583 Edits the rebar cover references of an entire rebar host or an individual face.
ColorSchemes48,739 Creates or modifies a color fill scheme for rooms and areas.
AnalyticalLink48,756 Creates an analytical element that connects two separate analytical nodes.
TrimOrExtendToCorner48,952 Trims or extends elements (such as walls or beams) to form a corner.
TrimOrExtendSingleElement48,953 Trims or extends one element (such as a wall, line, or beam) to a boundary defined by another element.
TrimOrExtendMultipleElements48,954 Trims or extends multiple elements (such as walls, lines, and beams) to a boundary defined by another element.
AlignedDimension48,955 Places dimensions between parallel references, or between multiple points.
LinearDimension48,956 Places horizontal or vertical dimensions that measure the distance between reference points.
AngularDimension48,957 Places a dimension that measures the angle between reference points sharing a common intersection.
RadialDimension48,958 Places a dimension that measures the radius of an inner curve or fillet.
ArcLengthDimension48,959 Places a dimension that measures the length of a curved wall or other element.
MeasureBetweenTwoReferences48,962 Measures the distance between two elements or references.
MeasureAlongAnElement48,963 Measures the length of an element.
MirrorDrawAxis49,000 Draws a temporary line to use as an axis for mirroring.
KeyboardShortcuts49,211 Assigns key sequences to tools.
BeamOrColumnJoins49,543 Adjusts how beams and columns frame into one another.
SaveAsTemplate49,783 Saves the current Revit project file as a template.
SaveAsFamily49,784 Saves the current family.
HalftoneOrUnderlay49,786 Customizes halftone and underlay elements in view.
Multiplanar50,051 Toggles the ability to define a rebar shape bent in more than one plane.
OpenProject51,800 Opens a Revit project.
LoadCases53,531 Adds and edits load cases for the analytical model.
LoadCombinations53,532 Adds and edits load combinations for the analytical model.
BoundaryConditionsSettings53,534 Selects the family symbol and adjusts the spacing for boundary conditions.
LoadsScalingDisplay53,538 Overrides the load type graphics scale using the project scale.
FindOrReplace53,591 Finds and replaces text in an open project file.
EnergySettings53,612 Specifies parameters used to create the energy analytical model.
Generate53,613 Creates the energy analytical model and generates design options and potential performance outcomes with Insight.
ExportGBXML53,615 Saves the model as a gbXML file.
GuideGrid53,675 Creates a new guide element in the active sheet to help align elements within and between sheets.
CreateAssembly53,677 Creates an assembly from elements you select in the drawing area.
StairTreadOrRiserNumber53,827 Creates a sequence of tread or riser numbers for a run in plan, elevation, or section views.
ManageConnectionToARevitServerAccelerator53,949 Specifies the Revit Server Accelerator to use for worksharing, or changes the accelerator to which you are connected.
RenderInCloud53,961 Renders 3D views online to create still images or interactive panoramas.
RenderGallery53,962 Opens your online gallery of completed and in-progress renderings in a web browser.
CreateEnergyModel53,964 Creates the energy analytical model.
DisplaceElements54,029 Creates a view-specific representation of model elements that can be displaced in the view.
GlobalParameters54,055 Specifies parameters that can be added to a project, and used to define values of other parameters.
Collaborate54,057 Enables collaboration so team members can work on a model simultaneously.
CollaborateInCloud54,058 Enables collaboration in the cloud, which allows team members to work on a model simultaneously.
PublishSettings54,064 Selects the views and sheets to publish to the cloud.
AssemblyCode54,096 Specifies the location of the assembly code file or reloads the assembly code table from the current file.
RevealObstacles54,111 Highlights categories that are considered obstacles in the view.
PathOfTravel54,122 Creates a path of travel along the shortest distance between 2 selected points.
MultipleValuesIndication54,124 Specifies the value indicated for a parameter when multiple elements with different parameter values are selected.
MultiplePaths54,125 Places multiple paths of travel between two selected points using a specified minimum path separation for each path.
OneWayIndicator54,126 Place a one-way annotation family into the view.
PeopleContent54,127 Place a family to indicate a person and a physical distance radius into the view.
SpatialGrid54,128 Place a square or hexagonal grid in a room element.
LoadFamilyIntoProjectAndClose54,133 Loads the family into open projects or family files and closes the family after it loads.
FabricationPart54,149 Displays the MEP Fabrication Parts palette.
LoadRebarShapeIntoProjectAndClose54,151 Loads the rebar shape into open projects or family files and closes the family after it loads.
Dynamo54,157 Provides access to Dynamo, an open source visual programming platform for designers.
DeleteEnergyModel54,224 Removes the energy analytical model from the Revit project.
Shorten54,264 Creates a shorten object on the selected beam that can trim or extend the beam.
CopeSkewed54,286 Creates a skewed cope at the selected beam end, either at the top or at the bottom.
CornerCut54,288 Creates a cut on the corner of a selected plate.
Welds54,290 Inserts a weld on one of the available edges of the model elements to be connected.
Plate54,292 Creates a structural plate in the building model.
Bolts54,293 Inserts bolts and the related holes in the selected model elements.
Holes54,294 Inserts holes on the selected face of model elements.
Anchors54,295 Inserts anchors and the related holes in the selected model elements.
ShearStuds54,296 Creates shear studs and the related welds on the selected face of model elements.
ContourCut54,297 Creates a contour cut on the selected faces of a beam or a plate.
Cope55,304 Creates a parametric cope on intersecting beams and the related connection between the beams.
Miter55,305 Creates a miter cut vertically or at the bisecting line of two beams and the related connection between the beams.
SawCutFlange55,306 Creates a cut on a beam adjusted according to the flange of another intersecting beam and the related connection between the beams.
SawCutWeb55,307 Creates a cut on a beam adjusted according to the web of another intersecting beam and the related connection between the beams.
CutThrough55,308 Creates a cut through a model element around the contour of another intersecting model element. The weld between the two elements is also created.
CutBy55,309 Creates a cut on a model element along the shape of another intersecting model element and a cut through the intersecting element. The connection between the two elements is also created.
ToggleHome56,242 Toggle Revit Home.
SaveAsCloudModel56,243 Saves the current Revit model to the cloud.
SystemsAnalysis56,254 Performs a systems analysis and generates a report for whole building energy simulation and analysis.
LinkPDF56,281 Inserts a link to a PDF into a model view.
LinkImage56,282 Inserts a link to an image into a model view.
AnalyticalMember56,298 Places an analytical member in the project.
BatchPrint56,308 Print a large number of drawings with a batch job.
WorksharingMonitor56,309 Launches Worksharing Monitor to manage a file-based workshared model.
SharedViews56,329 Opens and closes the Shared Views palette.
ResetSharedCoordinates56,335 Eliminate shared coordinates in the host model.
ElectricalAnalyticalLoadTypeSettings56,345 Opens the Electrical Analytical Load Type Settings dialog to define the power requirement for area-based loads.
OpenCloudModel56,379 Opens a Revit cloud model.
DynamoPlayerForSteel56,443 Places steel connections on selected elements using pre-defined rules.
PanelByBoundary56,448 Creates a planar analytical panel for the current work plane after a sketch of the contour.
Toposolid56,481 Creates a solid topographical element.
CreateFromImport56,504 Creates a solid topographical element.
AnalyticalAutomation56,516 Automates the creation, element connection, and update of the analytical model, using the physical representation as context.
RebarBendingDetail56,523 Creates realistic or schematic bar bending details for the selected individual rebar or sets.
PanelByExtrusion56,525 Creates an analytical panel perpendicular to the current work plane after a sketch of the path.
CoordinationModelLocal56,559 Links a NWD or NWC file to provide context for the Revit model.
CoordinationModelAutodeskDocs56,560 Links a coordination model view from Autodesk Docs into the current project.
Loads56,584 Defines point, line, and area loads in an analytical model.
PropertyLineData56,663 Define the angle display and units used when creating and labeling property lines.
PDF56,711 Creates PDF files.
CoordinationModelChanges56,713 Displays the overview of changes between the current version of a linked coordination model from Autodesk Docs and any of its previous versions.
ToposolidByFace56,723 Creates an element using a non-vertical face of a mass.
OperatingSchedules56,745 Opens the Building Operation Schedules Editor.
ToposolidSmoothShading56,764 Display toposolid elements in the model with smoothed surfaces.
LaunchAsApp56,806 Open the Content Catalog in a separate window.
LaunchInBrowser56,807 Access the Content Catalog in the default browser.
LaunchInDockedWindow56,808 Access the Content Catalog in the Revit session from a docked window.
SpaceNaming57,269 Assigns the names and numbers from architectural rooms to MEP spaces used for building performance analysis.
DynamoPlayer57,282 Preview, select, and run your Dynamo graphs from a single dialog.
RepairCentralModel57,283 Repairs a corrupt central model.
LinkTopography57,288 Links existing topography to the current Revit model.
Optimize57,289 Access energy and environmental performance data in Insight.
OpenRevitFile57,601 Opens any Revit file type.
Close57,602 Close Revit.
Save57,603 Saves the currently open project file.
SaveAsProject57,604 Saves the current Revit project file.
PrintSetup57,606 Specifies print options.
Print57,607 Sends the current drawing area or selected views and sheets to a printer or a printable file.
PrintPreview57,609 Displays a preview version of the current view or sheet to print.
CopyToClipboard57,634 Copies selected elements to the clipboard.
CutToClipboard57,635 Removes selected elements, and places them on the clipboard.
PasteFromClipboard57,637 Pastes elements from the clipboard into the current view.
TabViews57,650 Arranges all open views in the drawing area as tabs in a single window.
TileViews57,652 Arranges all open views within the application window, tiled so you can see each one in the drawing area.
CanvasTheme57,654 Sets the color theme of the canvas to dark or light.
ExitRevit57,665 Exit Revit.
StatusBar59,393 Displays the status bar at the bottom of the Revit window.
See Also