StructuralAssetClass Enumeration |
Represents the type of material described by a structural asset. This enum value is returned by Autodesk::Revit::DB::StructuralAsset::StructuralAssetClass.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum StructuralAssetClass
Public Enumeration StructuralAssetClass
public enum class StructuralAssetClass
type StructuralAssetClass
MembersMember name | Value | Description |
---|
Undefined | 0 |
Structural asset class is undefined.
|
Basic | 1 |
Structural asset class is basic.
|
Generic | 2 |
Structural asset class is generic.
|
Metal | 3 |
Structural asset class is metal.
|
Concrete | 4 |
Structural asset class is concrete.
|
Wood | 5 |
Structural asset class is wood.
|
Liquid | 6 |
Structural asset class is liquid.
|
Gas | 7 |
Structural asset class is gas.
|
Plastic | 8 |
Structural asset class is plastic.
|
See Also