SystemsAnalysisOptionsWeatherFile Property |
The file name of the EnergyPlus weather (*.epw).
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string WeatherFile { get; set; }
Public Property WeatherFile As String
Get
Set
public:
property String^ WeatherFile {
String^ get ();
void set (String^ value);
}
member WeatherFile : string with get, set
Property Value
String
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The analysis requires a valid EnergyPlus weather (.epw) file.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
When requesting a new system analysis, it is okay to have an empty weather file in the SystemsAnalysisOption. In that case,
the ViewSystemsAnalysisReport would use the weather file at the current site location.
See Also