ExportPDFSettingsGetOptions Method |
Gets a copy of options from settings for exporting.
Modification on this options would not change the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PDFExportOptions GetOptions()
Public Function GetOptions As PDFExportOptions
public:
PDFExportOptions^ GetOptions()
member GetOptions : unit -> PDFExportOptions
Return Value
PDFExportOptions
The options.
Remarks
Since the
[!:PDFExportOptions.FileName] is not serialized, when
[!:Combine]
is
(which means all the views would be exported into one PDF file, whose
file name is specified by
[!:PDFExportOptions.FileName]), the returned
PDFExportOptions
would have
[!:PDFExportOptions.FileName] as an empty string. The user has to
set the
[!:PDFExportOptions.FileName] before calling the
[!:Document.Export(string, IList{ElementId}, PDFExportOption)]
API exporting a "combined" PDF file.
See Also