RebarConstraintGetRebarConstraintTargetHostFaceType(Int32) Method |
Returns the RebarConstraintTargetHostFaceType of the host Element face to which
the RebarConstraint is attached. The RebarConstraintType of the RebarConstraint
must be 'FixedDistanceToHostFace' or 'ToCover'.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType(
int targetIndex
)
Public Function GetRebarConstraintTargetHostFaceType (
targetIndex As Integer
) As RebarConstraintTargetHostFaceType
public:
RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType(
int targetIndex
)
member GetRebarConstraintTargetHostFaceType :
targetIndex : int -> RebarConstraintTargetHostFaceType
Parameters
- targetIndex Int32
-
The index of the target. Should be between 0 and NumberOfTargets().
Return Value
RebarConstraintTargetHostFaceType
Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached.
ExceptionsException | Condition |
---|
ArgumentException |
targetIndex is out of range.
|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover'.
|
See Also