SchemaBuilderSetSchemaName Method

Sets the name of the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SchemaBuilder SetSchemaName(
	string schemaName
)

Parameters

schemaName  String
The name for the Schema.

Return Value

SchemaBuilder
The SchemaBuilder object may be used to add more settings.
Exceptions
ExceptionCondition
ArgumentException The parameter schemaName is not acceptable for naming Extensible Storage objects.
ArgumentNullException A non-optional argument was null
InvalidOperationException The SchemaBuilder has already finished building the Schema.
Remarks
The name is a user-friendly identifier of the Schema. GUIDs are used exclusively for Schema identity, but the name is useful to identify the Schema during development or in an error message. This field is required.
See Also