IExternalResourceServerGetIconPath Method |
Implement this method to return the path to an icon file which will be displayed in Revit
user interfaces associated to this server.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxFunction GetIconPath As String
abstract GetIconPath : unit -> string
Return Value
String
The image file of the server.
RemarksThe specified image will be displayed in the browser dialogs when the user is selecting
a resource of a compatible type.
The return must be the full path to an icon file containing 48x48, 32x32 and 16x16 pixel images.
If this method returns anything other than a valid icon file, a default image will be used for the server.
See Also