TriangulationInterfaceForTriangulatedSolidOrShell Class

This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTriangulationInterface
    Autodesk.Revit.DBTriangulationInterfaceForTriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TriangulationInterfaceForTriangulatedSolidOrShell : TriangulationInterface

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Constructors
 NameDescription
Public methodTriangulationInterfaceForTriangulatedSolidOrShell Construct an interface object for a TriangulatedSolidOrShell.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from TriangulationInterface)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from TriangulationInterface)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The vertex and triangle indices used by this class treat the triangulated solid or shell as if all the vertices and triangles of the different shell components were collected into single sets of vertices and triangles, respectively. For example, if a solid has two shell components and the first has ten vertices while the second has five vertices, vertexIndex 6 refers to vertex[6] of the first shell component, and vertexIndex 12 refers to vertex[2] of the second shell component. You can use the class TriangulationInterfaceForTriangulatedShellComponent to get a faceting of an individual shell component.
See Also