SystemsAnalysisOptionsWorkflowFile Property |
The file name of the EnergyPlus workflow script.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string WorkflowFile { get; set; }
Public Property WorkflowFile As String
Get
Set
public:
property String^ WorkflowFile {
String^ get ();
void set (String^ value);
}
member WorkflowFile : string with get, set
Property Value
String
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The analysis requires a valid workflow file.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
When requesting a new system analysis, it is okay to have an empty workflowFile in the SystemsAnalysisOption. In that case,
the ViewSystemsAnalysisReport would supply the weather file with the default value "HVAC Systems Loads and Sizing.osw".
See Also