MEPSystemAdd Method

Add elements into the system and connect them with the system using given connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual void Add(
	ConnectorSet connectors
)

Parameters

connectors  ConnectorSet
Connectors which are used to connect with the system.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument connectors is , or any connector in that collection is .
ArgumentException Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system.
InvalidOperationException Thrown when the operation failed.
ForbiddenForDynamicUpdateException Thrown if this method is called during dynamic update.
Remarks
Note: this method may not be called during dynamic update.
See Also