FamilyManagerReorderParameters Method |
Reorders the family parameters by the specified parameters order.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ReorderParameters(
IList<FamilyParameter> parameters
)
Public Sub ReorderParameters (
parameters As IList(Of FamilyParameter)
)
public:
void ReorderParameters(
IList<FamilyParameter^>^ parameters
)
member ReorderParameters :
parameters : IList<FamilyParameter> -> unit
Parameters
- parameters IListFamilyParameter
-
The new parameters order for the family.
The contents of this collection should consist of exactly the same parameters returned by the GetParameters() method.
This will include invisible parameters; they can be reordered but this will have no effect when viewing the parameters in the Revit UI.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when argument is or empty.
|
ArgumentException |
Thrown when the input parameters collection does not contain the same parameters as those returned by GetParameters().
|
InvalidOperationException |
Thrown when this family is a Rebar Shape family which doesn't support parameters reorder.
|
RemarksReordering the parameters only affects visible parameters within the same parameter group.
Parameters that belong to different groups will remain separated, and the groups' order will not be affected.
See Also