StructuralInstanceUsageFilter(StructuralInstanceUsage) Constructor

Constructs a new instance of a filter to match structural family instances (typically columns, beams, or braces) of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructuralInstanceUsageFilter(
	StructuralInstanceUsage structuralUsage
)

Parameters

structuralUsage  StructuralInstanceUsage
The family instance structural usage.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also