ExternalServiceGetDefaultServerId Method |
Returns the Id of the default server if one was assigned to the service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Guid GetDefaultServerId()
Public Function GetDefaultServerId As Guid
public:
Guid GetDefaultServerId()
member GetDefaultServerId : unit -> Guid
Return Value
Guid
The GUID of the default server, or an invalid GUID if there is none assigned.
Remarks
Only mandatory services have default servers assigned.
Only single-server and built-in multi-server services can currently be mandatory.
All other services that are optional don't have a default server.
See Also