RebarShapeVertexSetConstraints Method |
Assign a new list of constraints to this vertex.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetConstraints(
IList<RebarShapeConstraint> constraints
)
Public Sub SetConstraints (
constraints As IList(Of RebarShapeConstraint)
)
public:
void SetConstraints(
IList<RebarShapeConstraint^>^ constraints
)
member SetConstraints :
constraints : IList<RebarShapeConstraint> -> unit
Parameters
- constraints IListRebarShapeConstraint
-
A new list of constraints.
Exceptions
Remarks
Any existing constraints are discarded. The new constraints replace them.
Any parameters driving the constraints must already be added
with RebarShapeDefinition.AddParameter().
The allowable constraint types are:
- RebarShapeConstraintRadius
- RebarShapeConstraintArcLength
Any number of constraints may be specified. With no constraints,
the bend radius will default to the appropriate bend radius
from the RebarBarType element.
See Also