FloorGetNormalAtVerticalProjectionPoint Method |
Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical
projection of an arbitrary point in project space.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ GetNormalAtVerticalProjectionPoint(
XYZ modelLocation,
FloorFace floorFace
)
Public Function GetNormalAtVerticalProjectionPoint (
modelLocation As XYZ,
floorFace As FloorFace
) As XYZ
public:
XYZ^ GetNormalAtVerticalProjectionPoint(
XYZ^ modelLocation,
FloorFace floorFace
)
member GetNormalAtVerticalProjectionPoint :
modelLocation : XYZ *
floorFace : FloorFace -> XYZ
Parameters
- modelLocation XYZ
- A point in project coordinates whose vertical projection will determine the location at which
the normal will be taken.
- floorFace FloorFace
- A flag determining whether the top or bottom face of the floor should be used.
Return Value
XYZ Normal vector on the slab at the projection point.
Remarks If the floor is shape edited, the floor location at which we attempt to take the normal must be within the boundaries
of a face on the slab. Otherwise the method will return .
See Also