IExternalEventHandler Interface |
An interface to be executed when an external event is raised.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic interface IExternalEventHandler
Public Interface IExternalEventHandler
public interface class IExternalEventHandler
type IExternalEventHandler = interface end
The IExternalEventHandler type exposes the following members.
Methods | Name | Description |
---|
 | Execute |
This method is called to handle the external event.
|
 | GetName |
String identification of the event handler.
|
Top
Remarks
An instance of a class implementing this interface will be registered
with Revit first, and every time the corresponding external event
is raised, the Execute method of this interface will be invoked.
See Also