ExternalResourceReferenceGetResourceShortDisplayName Method |
Gets the short display name of the external resource.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string GetResourceShortDisplayName()
Public Function GetResourceShortDisplayName As String
public:
String^ GetResourceShortDisplayName()
member GetResourceShortDisplayName : unit -> string
Return Value
String
The short display name of the external resource.
ExceptionsException | Condition |
---|
InvalidOperationException |
The ExternalResourceReference (this ExternalResourceReference) is has no valid display path.
|
Remarks
For an external resource, such as a Rvt Link loaded from an external server, which has a full display path
such as "My Server://Nested/Nested_1.rvt", this function returns "Nested_1.rvt".
For an external resource, such as a Rvt Link loaded from the "built-in" server, which has a full display path
such as "c:\LocalLinks\Link_1.rvt", this function returns "Link_1.rvt".
See Also