DistributionSysTypeHighLegPhase Property |
The high-leg phase in the 3 phase 4 wires delta distribution system.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElectricalPhaseLine HighLegPhase { get; set; }
Public Property HighLegPhase As ElectricalPhaseLine
Get
Set
public:
property ElectricalPhaseLine HighLegPhase {
ElectricalPhaseLine get ();
void set (ElectricalPhaseLine value);
}
member HighLegPhase : ElectricalPhaseLine with get, set
Property Value
ElectricalPhaseLine
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The high-leg phase eHighLegPhase is not valid, only A, B, C is valid.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
When setting this property: The distribution system is not a 3 phase 4 wires delta distribution system.
|
See Also