BuiltInFailuresRebarCouplerFailures Class

Failures concerning couplers
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresRebarCouplerFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RebarCouplerFailures

The BuiltInFailuresRebarCouplerFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCantKeepConstraintsToBars The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.
Public propertyStatic memberCouplerRequiredRemoveFromGroup The coupler is invalid in group.
Public propertyStatic memberCouplerTypeInvalid This coupler type does not fit on the selected bar(s). Post error to delete the coupler.
Public propertyStatic memberDisconnectElements Disconnect the coupler from the connected bar.
Public propertyStatic memberDistanceBetweenBarsError This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.
Public propertyStatic memberDistanceBetweenBarsWarning This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.
Public propertyStatic memberEngagementBiggerThanLengthError This is used to post error. The sum of bar engagements is greater than the total coupler length.
Public propertyStatic memberEngagementBiggerThanLengthWarning This is used to post warning. The sum of bar engagements is greater than the total coupler length.
Public propertyStatic memberLengthParameterError This is used to post error. The "Total Length" parameter must be set to a strictly positive value.
Public propertyStatic memberLengthParameterWarning This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.
Public propertyStatic memberMainEngagementParameterError This is used to post error. "Bar Engagement 1" has an incorrect value.
Public propertyStatic memberMainEngagementParameterWarning This is used to post warning. "Bar Engagement 1" has an incorrect value.
Public propertyStatic memberNewCouplerTypeCreated A new coupler type was automatically created to fit the bar diameters.
Public propertyStatic memberNoBarSizeError This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".
Public propertyStatic memberNoBarSizeWarning This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".
Public propertyStatic memberNoTypeParamsDefinedWarning The parameters of the default type have no values.
Public propertyStatic memberSecondaryEngagementParameterError This is used to post error. "Bar Engagement 2" has an incorrect value.
Public propertyStatic memberSecondaryEngagementParameterWarning This is used to post warning. "Bar Engagement 2" has an incorrect value.
Public propertyStatic memberWidthParameterError This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.
Public propertyStatic memberWidthParameterWarning This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.
Top
See Also