FabricationRodInfoSetRodStructureExtension Method |
Set the length of the rod's top extension into structure. The rod must be attached to structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SetRodStructureExtension(
int rodIndex,
double extension
)
Public Function SetRodStructureExtension (
rodIndex As Integer,
extension As Double
) As Boolean
public:
bool SetRodStructureExtension(
int rodIndex,
double extension
)
member SetRodStructureExtension :
rodIndex : int *
extension : float -> bool
Parameters
- rodIndex Int32
-
The rod index.
- extension Double
-
Distance the rod will extend into the structure.
Return Value
Boolean
Returns true if it was successful otherwise false.
Exceptions
See Also