HermiteSplineTangentsStartTangent Property

The tangent vector at the start of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ StartTangent { get; set; }

Property Value

XYZ
This must be a nomalized unit vector.
Exceptions
ExceptionCondition
ArgumentNullException When setting this property: A non-optional argument was null
ArgumentOutOfRangeException When setting this property: startTangent is not length 1.0.
InapplicableDataException The start tangent value is not set.
See Also