ScheduleDefinitionGetFieldIndex Method

Converts a field ID to the corresponding field index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetFieldIndex(
	ScheduleFieldId fieldId
)

Parameters

fieldId  ScheduleFieldId
The field ID.

Return Value

Int32
The field index.
Exceptions
ExceptionCondition
ArgumentException fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException A non-optional argument was null
See Also