ElectricalCircuitPathMode Enumeration |
An enumerated type indicates the circuit path mode
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ElectricalCircuitPathMode
Public Enumeration ElectricalCircuitPathMode
public enum class ElectricalCircuitPathMode
type ElectricalCircuitPathMode
MembersMember name | Value | Description |
---|
Custom | 0 |
The circuit path is customized by user.
|
FarthestDevice | 1 |
The circuit path connects to the farthest devices.
|
AllDevices | 2 |
The circuit path connects to all the devices in the circuits, this mode is compatible to the legacy behavior.
|
See Also