DuctSizeSettingsAddSize Method

Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddSize(
	DuctShape shape,
	MEPSize sizeInfo
)

Parameters

shape  DuctShape
The shape of duct.
sizeInfo  MEPSize
The new MEPSize to be added.
Exceptions
ExceptionCondition
ArgumentException Throws if there is no size set determined by the duct shape or there is already the same size in the size set determined by the duct shape.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Throws if the function is called during iterating the size set.
See Also