EnergyAnalysisSpaceGetAnalyticalSurfaces Method |
Provides a way to access the collection of
analytical surfaces for a space.
Geometry data defining an analytical space volume.
Through an analytical surface you can connect a
source element with each polygon in a space.
The analytical surfaces defines an enclosed volume
bounded by the center plane of walls
and the top plane of roofs and floors.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<EnergyAnalysisSurface> GetAnalyticalSurfaces()
Public Function GetAnalyticalSurfaces As IList(Of EnergyAnalysisSurface)
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalSurfaces()
member GetAnalyticalSurfaces : unit -> IList<EnergyAnalysisSurface>
Return Value
IListEnergyAnalysisSurface
the collection of analytical surfaces for a space.
See Also