RebarContainerItemNumberOfBarPositions Property

The number of potential bars in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int NumberOfBarPositions { get; set; }

Property Value

Int32
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: the number of bar positions numberOfBarPositions is less than 1 or more than 1002.
InapplicableDataException When setting this property: This rebar element represents a single bar (the layout rule is Single).
Remarks
The number of positions is equal to the number of actual bars (the Quantity), plus one or two more positions depending on IncludeFistBar and IncludeLastBar.
See Also