SurfaceElementProjectionZ Enumeration |
Presets for given Analytical Projection Z.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum SurfaceElementProjectionZ
Public Enumeration SurfaceElementProjectionZ
public enum class SurfaceElementProjectionZ
type SurfaceElementProjectionZ
MembersMember name | Value | Description |
---|
TopOrInterior | 0 |
Top for floor or Interior Face for wall element.
|
CenterOfElement | 1 |
Center of element.
|
BottomOrExterior | 2 |
Bottom for floor or Exterior Face for wall element.
|
CenterOfCore | 3 |
Center of core.
Applicable for wall analytical model only.
|
Plane | 4 |
Use a Plane for projection (e.g., Grid, Level).
|
See Also