TableDataZoomLevel Property

The value of zoom level for corresponding TableView.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int ZoomLevel { get; set; }

Property Value

Int32
Exceptions
ExceptionCondition
ArgumentException When setting this property: The value of zoom level must be a multiple of 10 in the range of 10 to 400.
Remarks

This value is used to change the size of text fonts in tabular views, and then the size of rows, colums and cells will also be changed to satisfy the text.

Note: This value is only used to improve the text readability in tabular view and will not change the size of texts, rows, columns and cells in sheet views.

Note: This value is temporary setting just for this session.

Note: This value is a percentage number which must be a multiple of 10 in the range of 10 to 400. A value of 400 indicates the maximum zoom permitted. The default value for new created tabular views is 100.

See Also