AnalyticalSurfaceBaseIsOuterContourValid Method

Checks if contour is valid for this Analytical Surface.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsOuterContourValid(
	CurveLoop contour
)

Parameters

contour  CurveLoop
The curve loop to be checked.

Return Value

Boolean
Returns true if curve loop is ok, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
This method verifies if the contour is valid for a planar Analytical Surface or for a curved Analytical Panel.
See Also