MEPAnalyticalSegmentType Enumeration |
The type of analytical segment.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum MEPAnalyticalSegmentType
Public Enumeration MEPAnalyticalSegmentType
public enum class MEPAnalyticalSegmentType
type MEPAnalyticalSegmentType
MembersMember name | Value | Description |
---|
Undefined | 0 |
The segment is undefined.
|
Segment | 1 |
The segment is straight.
|
Fitting | 2 |
The segment is fitting.
|
Pump | 3 |
The segment is pump.
|
Loss | 4 |
The terminal loss (e.g., radiator, coil, etc.)
|
SourceEquipment | 5 |
The source equipment (e.g., chiller, boiler, etc.)
|
See Also