FailuresAccessorIsActive Method |
Method allows to check if this instance of the accessor is currently active.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function IsActive As Boolean
member IsActive : unit -> bool
Return Value
Boolean
True if this instance is currently active and can be used.
Remarks
Generally, this instance is active when it is passed to any of interfaces used in the process of failure resolution,
and becomes inactive after returning control to Revit.
The only special case is if failures processor returns WaitForUserInput,
in which case document stays in the FailureMode and instance of failures accessor stays active till FailureMode is ended.
See Also