BasePointClipped Property

Clipped state of the survey point (shared BasePoint). Change its state to clipped or unclipped, depending on how you want to move the survey point. To move the survey coordinate system in relation to the model, move the clipped survey point. To change the survey point to another location in the survey coordinate system, move the unclipped survey point. For project base point (non-shared BasePoint), this property will always return false. Trying to set the property will get an InvalidOperationException.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Clipped { get; set; }

Property Value

Boolean
Exceptions
ExceptionCondition
InvalidOperationException When setting this property: This operation is only available for a shared BasePoint.
See Also