PartialFailureResults Enumeration |
Possible results of the partial failure from invoking the DesignToFabricationConverter.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum PartialFailureResults
Public Enumeration PartialFailureResults
public enum class PartialFailureResults
type PartialFailureResults
MembersMember name | Value | Description |
---|
NotAllPartsConverted | 0 |
Not all design elements were converted.
|
InvalidConnections | 1 |
The connections are invalid.
|
HaveOpenConnectors | 2 |
Converted fabrication parts have open ends.
|
HaveDifferentOffsets | 3 |
Converted fabrication parts have different offsets.
|
NoMatchingSize | 4 |
There are no matching sizes found.
|
See Also