PanelScheduleTemplateCreate Method |
Creates a new instance of a panel schedule template.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static PanelScheduleTemplate Create(
Document document,
PanelScheduleType type,
PanelConfiguration config,
string strName
)
Public Shared Function Create (
document As Document,
type As PanelScheduleType,
config As PanelConfiguration,
strName As String
) As PanelScheduleTemplate
public:
static PanelScheduleTemplate^ Create(
Document^ document,
PanelScheduleType type,
PanelConfiguration config,
String^ strName
)
static member Create :
document : Document *
type : PanelScheduleType *
config : PanelConfiguration *
strName : string -> PanelScheduleTemplate
Parameters
- document Document
-
The document where the element will be created and added.
- type PanelScheduleType
-
The panel schedule type.
- config PanelConfiguration
-
The panel configuration type.
- strName String
-
The name of the panel schedule template to be created.
Return Value
PanelScheduleTemplate
The newly created panel schedule template element.
Exceptions
Remarks
If the given name has already been used by existing panel schedule templates,
a unique name will be used for the newly created template.
See Also