ViewTemplateApplicationOption Enumeration |
Options for applying view templates
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ViewTemplateApplicationOption
Public Enumeration ViewTemplateApplicationOption
public enum class ViewTemplateApplicationOption
type ViewTemplateApplicationOption
MembersMember name | Value | Description |
---|
AllParameters | 0 |
Apply all parameters controlled by template
|
UncontrolledParameters | 1 |
Apply only parameters controlled by template and not controlled by currently assigned view template
|
AllParametersAndStickIfNone | 2 |
Apply all parameters controlled by template and if none is currently assigned make it view template
|
See Also