DrawContextIsTransparentPass Method |
Determines whether the current rendering pass is for transparent objects.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsTransparentPass()
Public Shared Function IsTransparentPass As Boolean
public:
static bool IsTransparentPass()
static member IsTransparentPass : unit -> bool
Return Value
Boolean
True when the server should be submitting transparent objects for rendering, false otherwise.
ExceptionsException | Condition |
---|
InvalidOperationException |
This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
|
Remarks
See Also