CompoundStructureIsValid Method |
Checks for errors or inconsistencies in the data in this CompoundStructure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValid(
Document doc,
out IDictionary<int, CompoundStructureError> errMap,
out IDictionary<int, int> twoLayerErrorsMap
)
Public Function IsValid (
doc As Document,
<OutAttribute> ByRef errMap As IDictionary(Of Integer, CompoundStructureError),
<OutAttribute> ByRef twoLayerErrorsMap As IDictionary(Of Integer, Integer)
) As Boolean
public:
bool IsValid(
Document^ doc,
[OutAttribute] IDictionary<int, CompoundStructureError>^% errMap,
[OutAttribute] IDictionary<int, int>^% twoLayerErrorsMap
)
member IsValid :
doc : Document *
errMap : IDictionary<int, CompoundStructureError> byref *
twoLayerErrorsMap : IDictionary<int, int> byref -> bool
Parameters
- doc Document
-
Access to the document in which the CompoundStructure will be used.
- errMap IDictionaryInt32, CompoundStructureError
-
This map will associate each problematic layer index to a value in CompoundStructureError.
General structure errors are reported as associated to layer index -1.
- twoLayerErrorsMap IDictionaryInt32, Int32
-
The map is associated to a check run only for vertically Compound Structures.
Essentially the Compound Structure is sliced at representative heights.
It looks at the region from exterior to interior, and requires that the assigned layer indices do not decrease.
If they do, an entry is generated for this map. The first entry is the last valid layer index encountered.
The second entry is a region id whose assigned layer index is too small: it should be at least as large as the first entry.
Return Value
Boolean
True if the compound structure is valid for the document, false otherwise.
Exceptions
Remarks
This check is run before the CompoundStructure may be assigned to a particular ElementType.
See Also