DirectShapeApplicationDataId Property |
A text string that identifies the data to the creating application.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string ApplicationDataId { get; set; }
Public Property ApplicationDataId As String
Get
Set
public:
property String^ ApplicationDataId {
String^ get ();
void set (String^ value);
}
member ApplicationDataId : string with get, set
Property Value
String
Exceptions
Remarks
The intended use is to enable the creating application to identify the native data that was the source of this DirectShape.
However, the creating application may use any text string as appropriate for its purposes, or leave this property unset.
See Also