RebarUpdateCurvesDataSetHookPlaneNormalForBarIdx Method |
Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. This information is set to the rebar after the API execution is finished successfully.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex,
XYZ hookNormal
)
Public Sub SetHookPlaneNormalForBarIdx (
end As Integer,
barPositionIndex As Integer,
hookNormal As XYZ
)
public:
void SetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex,
XYZ^ hookNormal
)
member SetHookPlaneNormalForBarIdx :
end : int *
barPositionIndex : int *
hookNormal : XYZ -> unit
Parameters
- end Int32
-
The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex Int32
-
Index of the bar for which it will set hook plane normal.
- hookNormal XYZ
-
The normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Exceptions
Remarks
This information is set to the rebar after the API execution is finished successfully. Before setting the value a validation will be done.
We consider a hook plane normal valid if it's perpendicular with the bar direction at end.
See Also