ArcCreate(Plane, Double, Double, Double) Method |
Creates a new geometric arc object based on plane, radius, and angles.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Arc Create(
Plane plane,
double radius,
double startAngle,
double endAngle
)
Public Shared Function Create (
plane As Plane,
radius As Double,
startAngle As Double,
endAngle As Double
) As Arc
public:
static Arc^ Create(
Plane^ plane,
double radius,
double startAngle,
double endAngle
)
static member Create :
plane : Plane *
radius : float *
startAngle : float *
endAngle : float -> Arc
Parameters
- plane Plane
-
The plane which the arc resides. The plane's origin is the center of the arc.
- radius Double
-
The radius of the arc.
- startAngle Double
-
The start angle of the arc (in radians).
- endAngle Double
-
The end angle of the arc (in radians).
Return Value
Arc
The new arc.
Exceptions
Remarks
If the angle range is equal to or greater than 2 * PI, the curve will be
automatically converted to an unbounded circle.
ExampleArc CreateArcByGivingPlane(Autodesk.Revit.ApplicationServices.Application application, Plane plane)
{
double radius = 10;
double startAngle = 0;
double endAngle = 2 * Math.PI;
return Arc.Create(plane, radius, startAngle, endAngle);
}
Private Function CreateArcByGivingPlane(application As Autodesk.Revit.ApplicationServices.Application, plane As Plane) As Arc
Dim radius As Double = 10
Dim startAngle As Double = 0
Dim endAngle As Double = 2 * Math.PI
Return Arc.Create(plane, radius, startAngle, endAngle)
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also