TransactionGroupHasEnded Method |
Determines whether the transaction group has ended already.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function HasEnded As Boolean
member HasEnded : unit -> bool
Return Value
Boolean
True if the transaction group has already been committed or rolled back, False otherwise.
Remarks
A transaction is ended by completing either the
Commit
or
RollBack or
Assimilate method.
Another way of testing whether a transaction group has ended is by testing
its current status returned from (see
GetStatus). It must be either
'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'
See Also