SunAndShadowSettingsStartDateAndTime Property |
Identifies the start or current date and time.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DateTime StartDateAndTime { get; set; }
Public Property StartDateAndTime As DateTime
Get
Set
public:
property DateTime StartDateAndTime {
DateTime get ();
void set (DateTime value);
}
member StartDateAndTime : DateTime with get, set
Property Value
DateTime
The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be
in local time as well.
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.
|
Remarks
This property represents the start time for a single-day or multi-day study, or the current time
for a still sun study. Note that Revit may ignore this value if the SunriseToSunset flag is set.
See Also