MEPSpaceConstructionDuplicateConstruction Method |
Create a new construction for Space constructions.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic MEPBuildingConstruction DuplicateConstruction(
MEPBuildingConstruction pCurrentConstruction,
string pName
)
Public Function DuplicateConstruction (
pCurrentConstruction As MEPBuildingConstruction,
pName As String
) As MEPBuildingConstruction
public:
MEPBuildingConstruction^ DuplicateConstruction(
MEPBuildingConstruction^ pCurrentConstruction,
String^ pName
)
member DuplicateConstruction :
pCurrentConstruction : MEPBuildingConstruction *
pName : string -> MEPBuildingConstruction
Parameters
- pCurrentConstruction MEPBuildingConstruction
- The existing construction to be duplicated.
- pName String
- The name of the new construction.
Return Value
MEPBuildingConstruction
RemarksIf the name is same with the existing one, an exception will be thrown.
See Also