PerformanceAdviserGetRuleDescription(PerformanceAdviserRuleId) Method

Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetRuleDescription(
	PerformanceAdviserRuleId id
)

Parameters

id  PerformanceAdviserRuleId
The rule id to get information for.

Return Value

String
The description of the rule.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also